FAQ

From EditPlus Wiki
(Redirected from Frequently Asked Questions)
Jump to: navigation, search

This page exists to collect a growing number of frequently asked questions or FAQs, many of which have come up over time on the EditPlus Yahoo! Group.

Contents

What is EditPlus?

EditPlus is an advanced text editor, HTML editor and programmers editor for Windows with syntax highlighting, HTML toolbar, user tools, line number, ruler, URL highlighting, auto-completion, cliptext, column selection, powerful search and replace, multiple undo/redo, spell checker, customizable keyboard shortcuts, and more.

Who coded EditPlus?

EditPlus is developed by Sangil Kim (ES-Computing), who lives and works in Chinju, South Korea.

How can I make EditPlus my default text editor?

  1. Go to Tools / Preferences... / Files / Settings & syntax
  2. Select the File type for which you want EditPlus to be your default editor (like Text, PHP)
  3. Make sure that the extension you want to associate with EditPlus is listed in the File extensions field. Multiple extensions for the same file type are separated by a semicolon (";"). Example: php;php3;php4;inc
  4. Check Associate in Explorer

How can I use EditPlus to "View Source" in Mozilla Firefox?

See Firefox#Edit_Source_with_EditPlus.

How do I make EditPlus open with a blank document?

  1. Goto Tools > Preferences > General
  2. Check "Create new document on start up"

Or you can create a shortcut with the /n comand line option Like this "Right-Click" a blank space on your desktop or folder, and choose "New" and then Click "Shortcut" Then simply type in this C:\Program Files\EditPlus 2\editplus.exe /n (or whatever your path to editplus is) The reason I list this option, is because sometimes you will want to right click and open a file with EditPlus, and if the "Create new document on start up" is checked it will open your file, plus the new blank document, when all you want open is the file that you sent Edit+

How do I change the output of the HTML toolbar buttons?

  1. Edit the htmlbar.acp file under Program Files\EditPlus 2

How do I change the default HTML template?

  1. Edit the template.html file under Program Files\EditPlus 2

How do I add a new file type to the list under File > New?

  1. Create a new template file and save it in Program Files\EditPlus 2
  2. Select File > New > Configure Templates
  3. Click Add, set "Menu text" to the name of the file type and set the "File path" to the location of the template file

How do I make the HTML toolbar appear when editing a CSS or other file type?

  1. Goto Tools > Preferences > Settings & syntax
  2. Select CSS (or the appropriate file type) under "File types"
  3. Check "Show HTML toolbar"

How do I make EditPlus correctly highlight quoted strings in PHP that contain carriage returns and/or line feeds?

  1. Edit php.stx under Program Files\EditPlus 2
  2. Change #CONTINUE_QUOTE=n to #CONTINUE_QUOTE=y

How do I make EditPlus "correctly" highlight PHP heredoc strings?

  1. Edit php.stx under Program Files\EditPlus 2
  2. Add the COMMENTON2/COMMENTOFF2 lines below, where EOF is the heredoc identifer you plan to use in your PHP files. Alternatively you can leave out the EOF if you don't plan on having any semicolons in your heredoc strings
  3. Save php.stx
  4. Select Document > Refresh STX/ACP
  5. Select Tools > Preferences > Settings & syntax
  6. Select "PHP" under File types
  7. Select the "Syntax color" tab
  8. Make "Block Comment 2" the same color as Quotation and Quotation 2 (magenta is the default) or choose a unique color for heredoc strings
#COMMENTON2=<<<EOF
#COMMENTOFF2=EOF;

How do I make the Document Selector toolbar two rows high?

  1. Right click on the Document Selector toolbar
  2. Select "Options..."
  3. Set the "Number of rows" to 2

How do I make the middle mouse button (or scroll wheel) close a file on the Document Selector?

  1. Right-click on the Document Selector toolbar and select "Options..."
  2. Check "Close document with middle mouse button"
  3. Click OK

How do I make EditPlus correctly highlight the syntax of a file with no extension?

  1. Open the file in EditPlus
  2. Select Document > Change File Type
  3. Select the appropriate file syntax type

--or--

  1. Select Tools > Preferences
  2. Select Files > Settings & syntax
  3. Select "Default" from the list of file types
  4. In the "Syntax file" field, enter the path of the .stx file you want to use for files with no extension


How do I make EditPlus highlight the current (or active) line?

  1. Goto Tools > Preferences > General > Colors
  2. Select "Active line" in the Area box
  3. Uncheck the "Default" checkbox
  4. Select a color from "Background"

How can I comment out several lines of text at once, using line-comment indicators?

  1. Select the text you want to comment out and right click
  2. Select Format > Line Comment
  3. Enter the comment character or characters you wish to prepend to every selected line and click Ok

This method is also useful for appending any character(s) to the beginning of several lines. Some common types of line comment syntax includes:

// 
PHP, JSP, JavaScript, Java, C++, C#
Perl, PHP
(single apostrophe) Visual Basic
rem 
Most BASIC dialects, including Visual Basic
 ; 
(semicolon) many INI and CFG formats

How can I comment out several lines of text at once, using block-comment indicators?

The below method is useful for prepending and appending block-comment indicators to the beginning and end of selected-and-clipboard'ed lines for files of type: JSP, JavaScript, Java where /* marks the beginning of block-comment and */ marks the end of block-comment. For other file-types, substitute the /* and */ accordingly and proceed.

  1. Select some text in an open document within EditPlus.
  2. Start recording a macro by pressing CTRL + Q or by going to Tools, Record, Record Keystrokes... and assign a hot-key, say Alt+1 to it.
  3. You can also assign a label to the macro by pressing the Change Label... button.
  4. Press CTRL + X or go to Edit, Cut.
  5. Type /* and press Enter.
  6. Now press CTRL+V or go to Edit, Paste and press Enter.
  7. Type */ and end recording the Macro by pressing CTRL + Q or Tools, Record, Record Keystrokes.

You can also reassign a button on the HTML toolbar:

  1. Open the HTML toolbar auto-complete file htmlbar.acp in your EditPlus folder, e.g. C:\Program Files\EditPlus 3
  2. Decide which HTML toolbar icon you want to repurpose for block commenting, e.g. the Horizontal Rule (the button with two horizontal lines)
  3. Change this:

    #T=HR
    <HR>


    to this:

    #T=HR
    /*^!*/

How do I select a column or box of text?

  1. Turn Word-wrap mode off (use Ctrl+Shift+W to toggle on/off)
  2. Hold down the Alt key and use the mouse to select the column of text you want

or

  1. Turn Word-wrap mode off (use Ctrl+Shift+W to toggle on/off)
  2. Place the cursor where you want to start copying
  3. Press Alt+C, or right-click and choose Column Select
  4. Use arrow keys to select the column of text you want
  5. Press Enter or click the mouse to complete column selection

You can then copy, cut, delete, and paste the selected "box" of text. Note: use caution when pasting text copied with column selection. It will overwrite existing text that exists within the dimensions of the "box" of text being pasted. If you paste at the end of a long line, shorter lines are padded so that the pasted text retains its original columnar layout.

How can I modify the order of the tabs?

You can drag and drop the tabs from the main program window.

An alternative method: Invoke the Window List pressing F11. From there you can sort the selected tabs by using the Up and Down buttons.

How can I browse functions in my code?

Invoke the Function List pressing CTRL+F11.

How can I delete all empty lines in a text file?

See Search_and_Replace_Tricks#Delete_all_empty_lines

How can I change fonts? Where I can get new ones?

See Fonts.

Can I quit the editor or close all open documents with a single key press?

Yes, see Undocumented_Tricks#Close_all_files_pressing_ESC.

How do I enable/disable syntax highlighting (color coding)?

Toggle Syntax Highlighting on and off from the View menu.

Personal tools
Namespaces
Variants
Actions
Navigation
Toolbox