Difference between revisions of "FTP/SFTP"

From EditPlus Wiki
Jump to: navigation, search
m (Reverted edits by ErcacDelta (Talk); changed back to last version by Jumphog)
 
(7 intermediate revisions by 4 users not shown)
Line 1: Line 1:
Hull!
 
Dis site gets betta every time I visit it.
 
Great work guyz!
 
 
[http://z.la/c6k3g horny old grannies] |
 
[http://z.la/27w3o soccer moms nude] |
 
[http://z.la/ly17w perfect black tits] |
 
[http://z.la/4vl5i fuck my wife]
 
 
Hi guys,
 
I found so much useful things here.
 
Thank you.
 
 
[http://www.url4.net/E2A4EF mature lesbian teacher] |
 
[http://www.url4.net/DE69F6 free lesbian hentai] |
 
[http://www.url4.net/762B2A mature sluts] |
 
[http://www.url4.net/12F412 mature lesbian seduces young girl]
 
 
I feel like a complete blank.
 
That's how it is.
 
I can't be bothered with anything recently.
 
 
[http://www.url4.net/DE69F6 hentai lesbian] |
 
[http://www.url4.net/C3D98D free gay porn videos] |
 
[http://www.url4.net/A700F5 hairy mature] |
 
[http://www.url4.net/DB6612 young gay teens]
 
 
 
==SFTP Fix for OpenSSH==
 
==SFTP Fix for OpenSSH==
 
There is a limitation in EditPlus's implementation of SFTP that does not work with certain versions of OpenSSH.  OpenSSH is the most commonly used implemenation of SFTP on Linux.  If you can NOT to connect in EditPlus but you ARE with other applications (such as [http://filezilla.sf.net FileZilla], and the host is running OpenSSH version 3.8.1p1 or later, it could be that a simple configuration change on the server is all that is necessary to make it work.
 
There is a limitation in EditPlus's implementation of SFTP that does not work with certain versions of OpenSSH.  OpenSSH is the most commonly used implemenation of SFTP on Linux.  If you can NOT to connect in EditPlus but you ARE with other applications (such as [http://filezilla.sf.net FileZilla], and the host is running OpenSSH version 3.8.1p1 or later, it could be that a simple configuration change on the server is all that is necessary to make it work.
Line 44: Line 17:
 
==Simple SFTP [[Running on Linux|running EditPlus under Wine]]==
 
==Simple SFTP [[Running on Linux|running EditPlus under Wine]]==
 
This tip not only applies to EditPlus, but ANY *nix app. First, install Fuse[http://fuse.sourceforge.net/]. Then install the Fuse filesystem SSHFS [http://fuse.sourceforge.net/sshfs.html]. Now you can mount SFTP at a normal mount-point and open/save files just like you would to a local directory.
 
This tip not only applies to EditPlus, but ANY *nix app. First, install Fuse[http://fuse.sourceforge.net/]. Then install the Fuse filesystem SSHFS [http://fuse.sourceforge.net/sshfs.html]. Now you can mount SFTP at a normal mount-point and open/save files just like you would to a local directory.
 +
 +
==Keep FTP settings on upgrade to V3==
 +
It seems editplus now uses a unicode inifile for its ftp settings (I guess the filename ftp2_u.ini gives it away). To avoid entering in all your ftp servers when you upgrade convert your file like so:
 +
 +
*Open your old ftp2.ini
 +
*Find all occurances of 'sftp=0' and add 'utf8=0' on the line before
 +
*Save as ftp2_u.ini AND change the encoding to Unicode
  
 
==See also==
 
==See also==
 
*[[WinSCP]]
 
*[[WinSCP]]
 
*[http://www.eukhost.com/support/ftpdemo.php FTP Configuration Tutorials]
 
*[http://www.eukhost.com/support/ftpdemo.php FTP Configuration Tutorials]
 +
*[http://www.webhosting.uk.com/ftp.php Cute FTP/Smart FTP/WS FTP Configuration Tutorials]

Latest revision as of 07:20, 15 July 2008

SFTP Fix for OpenSSH

There is a limitation in EditPlus's implementation of SFTP that does not work with certain versions of OpenSSH. OpenSSH is the most commonly used implemenation of SFTP on Linux. If you can NOT to connect in EditPlus but you ARE with other applications (such as FileZilla, and the host is running OpenSSH version 3.8.1p1 or later, it could be that a simple configuration change on the server is all that is necessary to make it work.

Instructions:

  • Edit the sshd_config file (commonly located in /etc/ssh/).
  • Find the line that starts with: PasswordAuthentication.
  • Set it to yes instead of no.
  • Restart the SSH daemon by typing (as root): /etc/init.d/ssh restart
  • Alternatively use rcsshd restart if above doesnt work
  • Try to connect with EditPlus

Additional helps: To find out the version of SSH type: ssh -V
A very common version that contains the problem is: OpenSSH_3.8.1p1 Debian-8.sarge.4, OpenSSL 0.9.7e 25 Oct 2004
--Submitted by Dean Householder on 21 Apr 2006

Simple SFTP running EditPlus under Wine

This tip not only applies to EditPlus, but ANY *nix app. First, install Fuse[1]. Then install the Fuse filesystem SSHFS [2]. Now you can mount SFTP at a normal mount-point and open/save files just like you would to a local directory.

Keep FTP settings on upgrade to V3

It seems editplus now uses a unicode inifile for its ftp settings (I guess the filename ftp2_u.ini gives it away). To avoid entering in all your ftp servers when you upgrade convert your file like so:

  • Open your old ftp2.ini
  • Find all occurances of 'sftp=0' and add 'utf8=0' on the line before
  • Save as ftp2_u.ini AND change the encoding to Unicode

See also